• Hello, Guest! This is a public service announcement;

    GameServersHub is an official Tebex partner! Developers are now protected by chargeback protection and more!: Click Me (To Learn More)

PVP Scheduler

PVP Scheduler 1.8

No permission to download

Foppa

Administrator
Staff member
ㅤㅤ

Foppa

Administrator
Staff member
ㅤㅤ
ummmm okayy okayy thank you and yh hope one day it is fixed bcz it is something nice to have :)
This plugin is under development. It's quite complexed so be patient. Thanks for understanding.
 

anischalhoub

Well-known member
yup np take your time i know it is complex bcz it is a great plugins and need so much work :D anyw waiting the good news and good luck finishing it :D
 

Scrainer

Well-known member
Ofmg thanks michidu, u are so fcking awesome!!!
Could you fix teleport plugin? Please
Thanks!
 

Foppa

Administrator
Staff member
ㅤㅤ
Michidu, the option to "protect dinos" protects wild dinos too :S
Did you restart the server or reloaded the settings while the server was running after you have enable dino protection?
 

Isla Calavera

Well-known member
I think I'm doing something wrong, because I have been testing several hours and it does not work for me.

Today is Tuesday at 1:00 AM and I have this config.

"Days": [
{
"StartDay": 1,
"StartHour": 1,
"EndDay": 3,
"EndHour": 23,
"ProtectPlayers": true,
"ProtectDinos": true,
"ProtectStructures": true,
"PVPEnabledMessage": "<RichColor Color = \" 1, 0, 0, 1 \ "> PVP is activated!. </>",
"PVPDisabledMessage": "<RichColor Color = \" 0, 1, 0, 1 \ "> PVP is disabled!. </>"
}
]
}
}

I tested a lot of thinks but dont work never for me. Anyone know what im doing worng?.


Ty
 

Foppa

Administrator
Staff member
ㅤㅤ
I think I'm doing something wrong, because I have been testing several hours and it does not work for me.

Today is Tuesday at 1:00 AM and I have this config.

"Days": [
{
"StartDay": 1,
"StartHour": 1,
"EndDay": 3,
"EndHour": 23,
"ProtectPlayers": true,
"ProtectDinos": true,
"ProtectStructures": true,
"PVPEnabledMessage": "<RichColor Color = \" 1, 0, 0, 1 \ "> PVP is activated!. </>",
"PVPDisabledMessage": "<RichColor Color = \" 0, 1, 0, 1 \ "> PVP is disabled!. </>"
}
]
}
}

I tested a lot of thinks but dont work never for me. Anyone know what im doing worng?.


Ty
Explain what you want to achieve?
By reading your config you are Protecting everything from Monday @ 01:00 to Wednesday @ 23:00. Before this version, it might have been done the other way around but to fix this it was decided the most logical way is to actually set time for when you want the protection should be active.

Hope this clears up the confusion! :)
 

Isla Calavera

Well-known member
Explain what you want to achieve?
By reading your config you are Protecting everything from Monday @ 01:00 to Wednesday @ 23:00. Before this version, it might have been done the other way around but to fix this it was decided the most logical way is to actually set time for when you want the protection should be active.

Hope this clears up the confusion! :)

Thanks for the clarification, it is really how I understood it and how I was testing it, with that same configuration, right now I enter the server and there is damage, the server has been restarted so that it loads everything again, even in the restart it tells you the configuration and there should be no harm.
 

Foppa

Administrator
Staff member
ㅤㅤ
Thanks for the clarification, it is really how I understood it and how I was testing it, with that same configuration, right now I enter the server and there is damage, the server has been restarted so that it loads everything again, even in the restart it tells you the configuration and there should be no harm.
Have you enabled PvP on the server?
Try changing the code to this instead it might help:
JSON:
{
   "PVPScheduler":{
      "ServerName":"Isla Calavera",
      "NotifyServer":true,
      "LogPvpSwitchAtConsole":true,
      "Days":[
         {
            "StartDay":1,
            "StartHour":1,
            "EndDay":2,
            "EndHour":0,
            "ProtectPlayers":true,
            "ProtectDinos":true,
            "ProtectStructures":true,
            "PVPEnabledMessage":"<RichColor Color=\"1, 0, 0, 1\">Monday Raid Protection is now enabled.</>",
            "PVPDisabledMessage":"<RichColor Color=\"0, 1, 0, 1\">Monday Raid Protection is now disabled.</>"
         },
         {
            "StartDay":2,
            "StartHour":0,
            "EndDay":3,
            "EndHour":0,
            "ProtectPlayers":true,
            "ProtectDinos":true,
            "ProtectStructures":true,
            "PVPEnabledMessage":"<RichColor Color=\"1, 0, 0, 1\">Tuesday Raid Protection is now enabled.</>",
            "PVPDisabledMessage":"<RichColor Color=\"0, 1, 0, 1\">Tuesday Raid Protection is now disabled.</>"
         },
         {
            "StartDay":3,
            "StartHour":0,
            "EndDay":3,
            "EndHour":23,
            "ProtectPlayers":true,
            "ProtectDinos":true,
            "ProtectStructures":true,
            "PVPEnabledMessage":"<RichColor Color=\"1, 0, 0, 1\">Wednesday Raid Protection is now enabled.</>",
            "PVPDisabledMessage":"<RichColor Color=\"0, 1, 0, 1\">Wednesday Raid Protection is now disabled.</>"
         }    
      ]
   }
}
 

Isla Calavera

Well-known member
Have you enabled PvP on the server?
Try changing the code to this instead it might help:
JSON:
{
   "PVPScheduler":{
      "ServerName":"Isla Calavera",
      "NotifyServer":true,
      "LogPvpSwitchAtConsole":true,
      "Days":[
         {
            "StartDay":1,
            "StartHour":1,
            "EndDay":2,
            "EndHour":0,
            "ProtectPlayers":true,
            "ProtectDinos":true,
            "ProtectStructures":true,
            "PVPEnabledMessage":"<RichColor Color=\"1, 0, 0, 1\">Monday Raid Protection is now enabled.</>",
            "PVPDisabledMessage":"<RichColor Color=\"0, 1, 0, 1\">Monday Raid Protection is now disabled.</>"
         },
         {
            "StartDay":2,
            "StartHour":0,
            "EndDay":3,
            "EndHour":0,
            "ProtectPlayers":true,
            "ProtectDinos":true,
            "ProtectStructures":true,
            "PVPEnabledMessage":"<RichColor Color=\"1, 0, 0, 1\">Tuesday Raid Protection is now enabled.</>",
            "PVPDisabledMessage":"<RichColor Color=\"0, 1, 0, 1\">Tuesday Raid Protection is now disabled.</>"
         },
         {
            "StartDay":3,
            "StartHour":0,
            "EndDay":3,
            "EndHour":23,
            "ProtectPlayers":true,
            "ProtectDinos":true,
            "ProtectStructures":true,
            "PVPEnabledMessage":"<RichColor Color=\"1, 0, 0, 1\">Wednesday Raid Protection is now enabled.</>",
            "PVPDisabledMessage":"<RichColor Color=\"0, 1, 0, 1\">Wednesday Raid Protection is now disabled.</>"
         }   
      ]
   }
}


Yes, i had.

I will try this. Thanks.
 

Foppa

Administrator
Staff member
ㅤㅤ
anyone got this to work as not working for me not showing when its active or not active also its allowing me to blow things up
I am running this on 3 servers and it works. During my tests there was some issues with wild dinos become unkillable if you use the dino protection.
 
Nitrado Console Servers Partner
Top